読者です 読者をやめる 読者になる 読者になる

hotoolong's blog

Railsやvimや気になったことを綴ってます

いつの間にかvim起動時にpythonが必要だといわたので、

東京も雪の影響で交通機関が麻痺してたりしましたが、
おかげさまで、仕事に行かなくてよくなったので連続出勤記録を21でストップさせることが出来ました。

それはさておき、
タイトルのとおりだが、
vim起動時に

You need vim compiled with Python 2.6+ or 3.2+ support for Powerline to work. Please consult the documentation for more details.

とエラーがでるうになってしまったので、
vimを再インストールしなおしたのだが、
brewからインストールできるようなのでそっちで入れてみた。

brew install vim --enable-interp=python,python3,ruby

http://d.hatena.ne.jp/TaRO/20130701/1372701741

+cryptv +linebreak +python +viminfo
+cscope +lispindent -python3 +vreplace

エラーは出なくなったものの3は入ってない模様。。